How To Solution SDconnect Toolkit NOT Works, Start with an Error

Here are mbstartool customer solutions of what to do if SDconnect Toolkit COM-Server has stopped functioning.

Here are customer solutions of what to do if SD connect Toolkit COM-Server has stopped functioning.

 

Some folks inform tried and solved it this way. (i have not tried this)

1. Open Taskmanager an Kill all Processes of SDconnect Toolkit(Tkserver.exe, Tktray.exe).
2. Go to DTS install folder and find the folder with the Tkserver.exe in it.
3. Delete this folder.
4. Install SDconnect toolkit from here:
https://mega.nz/#!rgExUb7Z

encryption key: fQAtu6sTOfHFhfQi5ZObBJr742wGa7_CXuLY33JLhfc

  1. Go to original SDconnect Path (C:\Program Files (x86)\Mercedes-Benz\SDconnect Toolkit\
    6. Copy filesToolkit.ini + SDVersion.dll
    7. Paste Toolkit.ini in C:\ProgramData\I+ME ACTIA\Toolkit\ and SDVersion.dll in Install-Directory of the new SDconnect Toolkit.
    8. Start SDconnect Toolkit from Startmenu (the SDconnect folder in Root of “All Programs”, not the one in “Mercedes-Benz” folder)

but i have another way that seems to work.
have not tried on vehicle yet but at least i get no more errors.

my base is a win 7 x64 system.
i have a clean and working installation of xentry xdos 05.2016.
but it should work with other Xentry versions too.

Now you install DTS Monaco and the Daimler Addon.
In my case it was Monaco 8.3.12 and the “setup_addon_dag.exe”.
Now restart the PC. You notice that the sdconnect toolkit does not start anymore.
Delete the “Start SDconnect Server” shortcut from the autostart folder.
Now restart the pc again or open the taskmanager and kill the process TkTray.exe and TkServer.exe.

Now you browse to “C:\Program Files (x86)\Mercedes-Benz\SDConnect toolkit\”.
Copy everything that is in that folder. (should be 6 subfolders, bin, doc, selftest and the update folders)

Now browse to “C:\Program Files (x86)\Softing\Diagnostic Tool Set 8\8.03\Interfaces\DCDI_DPduApi\eCOM_Toolkit”.
Delete everything that is in this folder.
Now paste the folders/files you copied from the Mercedes folder here.

Open the “bin” folder and copy the toolkit.ini file.
Or go back to the Mercedes folder and copy the toolkit.ini file from there.
Paste and replace this file into “C:\ProgramData\I+ME ACTIA\Toolkit”
(Note, the C:\ProgramData folder:

It is a hidden folderon Win7. I do not talk about c:\program files\ or c:\program files (x86)\ (name of these folders might be different if your windows is not english)
(you can get the right folder by opening the explorer and typing in the adress bar %programdata%)

With Win XP i guess the right folder could be something like “C:\Documents and Settings\All Users\Application Data”.
You could also try to just search for the toolkit.ini file on the whole C:\ drive. Should give you the location as well.)

Now restart the pc again.

In my case, deleting the autostart prevents the toolkit to start from the mercedes folder.
thanks to monaco the toolkit from the softing/interfaces/ecom folder will now start.
by replacing the toolkit in that folder we trick the system into starting a copy of the original toolkit.
my toolkit now starts without an error. i can open it again and everything seems to work. before it did not start at all or i got error messages.

 

Src :
http://blog.mbstartool.com/2017/08/15/solved-sdconnect-toolkit-not-works-start-with-an-error/

Share